using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\R(?:\1(?:\R|$))+";
string substitution = @"";
string input = @"192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}