$re = '/^(.+)\R(?:\1(?:\R|$))+/m';
$str = '192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;