#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)\R(?:\1(?:\R|$))+"
Local $sString = "192.168.0.1" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.168.0.2" & @CRLF & _
"192.168.0.3" & @CRLF & _
"192.168.0.3" & @CRLF & _
"192.168.0.4" & @CRLF & _
"192.168.0.5" & @CRLF & _
"192.168.0.5" & @CRLF & _
"192.168.0.6"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)