#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(((::){0,1}[_A-z][_A-z0-9]*)+)$"
Local $sString = "monkey" & @CRLF & _
"dog" & @CRLF & _
"dog8_" & @CRLF & _
"_dog8" & @CRLF & _
"8dog_" & @CRLF & _
"::std" & @CRLF & _
"::monkey" & @CRLF & _
"::monkey::dog::cat" & @CRLF & _
"::monkey::8dog::cat" & @CRLF & _
"::frog" & @CRLF & _
"::7frog" & @CRLF & _
"boost::asio" & @CRLF & _
"::boost::asio"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)