const regex = /^(((::){0,1}[_A-z][_A-z0-9]*)+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((::){0,1}[_A-z][_A-z0-9]*)+)$', 'gm')
const str = `monkey
dog
dog8_
_dog8
8dog_
::std
::monkey
::monkey::dog::cat
::monkey::8dog::cat
::frog
::7frog
boost::asio
::boost::asio`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);