use strict;
my $str = 'monkey
dog
dog8_
_dog8
8dog_
::std
::monkey
::monkey::dog::cat
::monkey::8dog::cat
::frog
::7frog
boost::asio
::boost::asio';
my $regex = qr/^(((::){0,1}[_A-z][_A-z0-9]*)+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";