package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((::){0,1}[_A-z][_A-z0-9]*)+)$`)
var str = `monkey
dog
dog8_
_dog8
8dog_
::std
::monkey
::monkey::dog::cat
::monkey::8dog::cat
::frog
::7frog
boost::asio
::boost::asio`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}