import re
regex = re.compile(r"^(((::){0,1}[_A-z][_A-z0-9]*)+)$", flags=re.MULTILINE)
test_str = ("monkey\n"
"dog\n"
"dog8_\n"
"_dog8\n"
"8dog_\n"
"::std\n"
"::monkey\n"
"::monkey::dog::cat\n"
"::monkey::8dog::cat\n"
"::frog\n"
"::7frog\n"
"boost::asio\n"
"::boost::asio")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)