#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?X)(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$"
Local $sString = "1 foo 745" & @CRLF & _
"2 baz 746" & @CRLF & _
"garbage"
Local $sSubst = "$1;$2;$3\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)