re = /(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$/
str = '1 foo 745
2 baz 746
garbage'
subst = '$1;$2;$3\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result