import Foundation
// WARNING: You included a flag that Swift doesn't support: X
// When this flag is set, it causes any backslash in the pattern that is followed by a letter that has no special meaning to cause an error.
// By default in Swift, a backslash followed by a letter with no special meaning will be treated as a literal.
let pattern = #"(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 foo 745
2 baz 746
garbage
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1;$2;$3\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)