package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$`)
var str = `1 foo 745
2 baz 746
garbage`
var substitution = "$1;$2;$3\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}