use strict;
my $str = '1 foo 745
2 baz 746
garbage';
my $regex = qr/(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$/p;
my $subst = '$1;$2;$3\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";