// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?)(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$").unwrap();
let string = "1 foo 745
2 baz 746
garbage";
let substitution = "$1;$2;$3\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}