$re = '/(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$/X';
$str = '1 foo 745
2 baz 746
garbage';
$subst = "$1;$2;$3\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;