# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>/<img $1\/>/gim;t' <<< "<img src=\"images/a.jpg\" title=\"test\"><br/>
<img src=\"b.jpg\" />
<imgi src=\"b.jpg\" >
<img src=\"a/b.jpg\" >
<span><img src=\"ab.jpg\"></span>
<img src=\"\" title=\"\">
<img src=\"\" data-val>
<img src=\"2\" / >
<img src=\"c.jpg\" title=\"a'>b\">
<img src=\"c.jpg\" title='a\">b'>
<img src=\"c.jpg\" title='a>=b\"=>' >"