import Foundation
let pattern = #"<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<img src="images/a.jpg" title="test"><br/>
<img src="b.jpg" />
<imgi src="b.jpg" >
<img src="a/b.jpg" >
<span><img src="ab.jpg"></span>
<img src="" title="">
<img src="" data-val>
<img src="2" / >
<img src="c.jpg" title="a'>b">
<img src="c.jpg" title='a">b'>
<img src="c.jpg" title='a>=b"=>' >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img $1/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)