$re = '/<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>/im';
$str = '<img src="images/a.jpg" title="test"><br/>
<img src="b.jpg" />
<imgi src="b.jpg" >
<img src="a/b.jpg" >
<span><img src="ab.jpg"></span>
<img src="" title="">
<img src="" data-val>
<img src="2" / >
<img src="c.jpg" title="a\'>b">
<img src="c.jpg" title=\'a">b\'>
<img src="c.jpg" title=\'a>=b"=>\' >';
$subst = "<img $1/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;