#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>"
Local $sString = "<img src="images/a.jpg" title="test"><br/>" & @CRLF & _
"<img src="b.jpg" />" & @CRLF & _
"<imgi src="b.jpg" >" & @CRLF & _
"<img src="a/b.jpg" >" & @CRLF & _
"<span><img src="ab.jpg"></span>" & @CRLF & _
"<img src="" title="">" & @CRLF & _
"<img src="" data-val>" & @CRLF & _
"<img src="2" / >" & @CRLF & _
"<img src="c.jpg" title="a'>b">" & @CRLF & _
"<img src="c.jpg" title='a">b'>" & @CRLF & _
"<img src="c.jpg" title='a>=b"=>' >"
Local $sSubst = "<img $1/>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)