const regex = /<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*img\\s+([^>]*=(?:\\".*?\\"|\\\'.*?\\\'))[\\s\\w\\-]*>', 'gim')
const str = `<img src="images/a.jpg" title="test"><br/>
<img src="b.jpg" />
<imgi src="b.jpg" >
<img src="a/b.jpg" >
<span><img src="ab.jpg"></span>
<img src="" title="">
<img src="" data-val>
<img src="2" / >
<img src="c.jpg" title="a'>b">
<img src="c.jpg" title='a">b'>
<img src="c.jpg" title='a>=b"=>' >`;
const subst = `<img $1/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);