package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>`)
var str = `<img src="images/a.jpg" title="test"><br/>
<img src="b.jpg" />
<imgi src="b.jpg" >
<img src="a/b.jpg" >
<span><img src="ab.jpg"></span>
<img src="" title="">
<img src="" data-val>
<img src="2" / >
<img src="c.jpg" title="a'>b">
<img src="c.jpg" title='a">b'>
<img src="c.jpg" title='a>=b"=>' >`
var substitution = "<img $1/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}