import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*img\\s+([^>]*=(?:\\\".*?\\\"|\\'.*?\\'))[\\s\\w\\-]*>";
final String string = "<img src=\"images/a.jpg\" title=\"test\"><br/>\n"
+ "<img src=\"b.jpg\" />\n"
+ "<imgi src=\"b.jpg\" >\n"
+ "<img src=\"a/b.jpg\" >\n"
+ "<span><img src=\"ab.jpg\"></span>\n"
+ "<img src=\"\" title=\"\">\n"
+ "<img src=\"\" data-val>\n"
+ "<img src=\"2\" / >\n"
+ "<img src=\"c.jpg\" title=\"a'>b\">\n"
+ "<img src=\"c.jpg\" title='a\">b'>\n"
+ "<img src=\"c.jpg\" title='a>=b\"=>' >";
final String subst = "<img $1/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}