using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*img\s+([^>]*=(?:\"".*?\""|\'.*?\'))[\s\w\-]*>";
string substitution = @"<img $1/>";
string input = @"<img src=""images/a.jpg"" title=""test""><br/>
<img src=""b.jpg"" />
<imgi src=""b.jpg"" >
<img src=""a/b.jpg"" >
<span><img src=""ab.jpg""></span>
<img src="" title="">
<img src="" data-val>
<img src=""2"" / >
<img src=""c.jpg"" title=""a'>b"">
<img src=""c.jpg"" title='a"">b'>
<img src=""c.jpg"" title='a>=b""=>' >";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}