# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\s*img\s+([^>]*=(?:\".*?\"|\'.*?\'))[\s\w\-]*>"
test_str = ("<img src=\"images/a.jpg\" title=\"test\"><br/>\n"
"<img src=\"b.jpg\" />\n"
"<imgi src=\"b.jpg\" >\n"
"<img src=\"a/b.jpg\" >\n"
"<span><img src=\"ab.jpg\"></span>\n"
"<img src=\"\" title=\"\">\n"
"<img src=\"\" data-val>\n"
"<img src=\"2\" / >\n"
"<img src=\"c.jpg\" title=\"a'>b\">\n"
"<img src=\"c.jpg\" title='a\">b'>\n"
"<img src=\"c.jpg\" title='a>=b\"=>' >")
subst = "<img $1/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.