using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$";
string substitution = @"";
string input = @"15011020699";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}