re = /^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$/m
str = '15011020699'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result