use strict;
my $str = '15011020699';
my $regex = qr/^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";