import Foundation
let pattern = #"^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"15011020699"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)