const regex = /^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1{1}(3{1}\\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\\d{8}$', 'gm')
const str = `15011020699`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);