# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http:\\/\\/\S*\\/([^\\/]+)\.pdf/$0?pdf=$1/g;t' <<< "http://mysite/strategy/annual-plan-16-17.pdf"