#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "http:\/\/\S*\/([^\/]+)\.pdf"
Local $sString = "http://mysite/strategy/annual-plan-16-17.pdf"
Local $sSubst = "$0?pdf=$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)