const regex = /http:\/\/\S*\/([^\/]+)\.pdf/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/\\S*\\\/([^\\\/]+)\\.pdf', 'g')
const str = `http://mysite/strategy/annual-plan-16-17.pdf`;
const subst = `$0?pdf=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);