// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http:\/\/\S*\/([^\/]+)\.pdf").unwrap();
let string = "http://mysite/strategy/annual-plan-16-17.pdf";
let substitution = "$0?pdf=$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}