import Foundation
let pattern = #"http:\/\/\S*\/([^\/]+)\.pdf"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://mysite/strategy/annual-plan-16-17.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0?pdf=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)