use strict;
my $str = 'http://mysite/strategy/annual-plan-16-17.pdf';
my $regex = qr/http:\/\/\S*\/([^\/]+)\.pdf/p;
my $subst = '$0?pdf=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";