package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/\S*\/([^\/]+)\.pdf`)
var str = `http://mysite/strategy/annual-plan-16-17.pdf`
var substitution = "$0?pdf=$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}