$re = '/http:\/\/\S*\/([^\/]+)\.pdf/';
$str = 'http://mysite/strategy/annual-plan-16-17.pdf';
$subst = "$0?pdf=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;