# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/adliye?adliye\\/(.+)$/\/sozluk?=$1/gm;t' <<< "657.com.tr/adliye?adliye=Polatlı
"