use strict;
my $str = '657.com.tr/adliye?adliye=Polatlı
';
my $regex = qr/\/adliye?adliye\/(.+)$/mp;
my $subst = '/sozluk?=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";