re = /\/adliye?adliye\/(.+)$/m
str = '657.com.tr/adliye?adliye=Polatlı
'
subst = '/sozluk?=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result