const regex = /\/adliye?adliye\/(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/adliye?adliye\\\/(.+)$', 'gm')
const str = `657.com.tr/adliye?adliye=Polatlı
`;
const subst = `/sozluk?=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);