import Foundation
let pattern = #"\/adliye?adliye\/(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
657.com.tr/adliye?adliye=Polatlı
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/sozluk?=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)