using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/adliye?adliye\/(.+)$";
string substitution = @"/sozluk?=$1";
string input = @"657.com.tr/adliye?adliye=Polatlı
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}