#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Pop,|,Pop|^Pop$"
Local $sString = "Pop" & @CRLF & _
"Pop,R'n'B,Classic Rock" & @CRLF & _
"Dance,Pop,R'n'B,Classic Rock" & @CRLF & _
"Dance,R'n'B,Pop"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)