const regex = /Pop,|,Pop|^Pop$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Pop,|,Pop|^Pop$', 'gm')
const str = `Pop
Pop,R'n'B,Classic Rock
Dance,Pop,R'n'B,Classic Rock
Dance,R'n'B,Pop`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);