$re = '/Pop,|,Pop|^Pop$/m';
$str = 'Pop
Pop,R\'n\'B,Classic Rock
Dance,Pop,R\'n\'B,Classic Rock
Dance,R\'n\'B,Pop';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;