import re
regex = re.compile(r"Pop,|,Pop|^Pop$", flags=re.MULTILINE)
test_str = ("Pop\n"
"Pop,R'n'B,Classic Rock\n"
"Dance,Pop,R'n'B,Classic Rock\n"
"Dance,R'n'B,Pop")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)