use strict;
my $str = 'Pop
Pop,R\'n\'B,Classic Rock
Dance,Pop,R\'n\'B,Classic Rock
Dance,R\'n\'B,Pop';
my $regex = qr/Pop,|,Pop|^Pop$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";