package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Pop,|,Pop|^Pop$`)
var str = `Pop
Pop,R'n'B,Classic Rock
Dance,Pop,R'n'B,Classic Rock
Dance,R'n'B,Pop`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}