# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\S) +(?=\S)/ /gm;t' <<< "normal string foo bar qux
leading spaces are ok
trailing spaces are not affected "